[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [fix ancient snake-2 syntax] ./build/getversion.py

From: Hyrum K Wright <hyrum.wright_at_wandisco.com>
Date: Thu, 4 Aug 2011 16:33:10 -0500

On Wed, Aug 3, 2011 at 2:28 PM, Peter Samuelson <peter_at_p12n.org> wrote:
>
>> On Wed, Aug 3, 2011 at 3:03 PM, Peter Samuelson <peter_at_p12n.org> wrote:
>> > Further checking: the new exception syntax is new to Python 2.6.
>> > Given that this script is only used in dev builds (not from
>> > tarballs), someone remind me: what's our Py version requirement for
>> > dev builds?  It is not specified in INSTALL.
>
> [Mark Phippard]
>> In our 1.6 release we bumped it up to 2.4.  I believe it was 2.2
>> before that.
>
> Eh ... that's the case for release builds, documented in INSTALL.
> I thought we had a tighter Python requirement for dev builds, though.

I think we've been operating under a 2.4 assumption for dev builds,
but other bits have slowly crept in. I would not be opposed to
bumping the dev requirement to 2.6, as most distros seem to be running
at least that these days.

-Hyrum

-- 
uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/
Received on 2011-08-04 23:33:39 CEST

This is an archived mail posted to the Subversion Dev mailing list.