[RFC] Rename 'svn_error_return' to 'svn_error_trace'?
From: Julian Foad <julian.foad_at_wandisco.com>
Date: Thu, 23 Jun 2011 11:08:41 +0100
Another new-in-1.7 API. A rather trivial one, this, and I don't want
cmt_err = svn_error_return(
return svn_error_return(
return svn_error_return(err);
... I think the word "return" sounds out of place in the first example
cmt_err = svn_error_trace(
return svn_error_trace(
return svn_error_trace(err);
Any objections to me doing a global search an replace? It's code churn,
We could go one step further and define a statement-macro similar to
#define SVN_ERR_RETURN(err) return svn_error_trace(err)
cmt_err = svn_error_trace(
SVN_ERR_RETURN(svn_ra_check_path(cukb->session, ...));
SVN_ERR_RETURN(err);
I'm not currently proposing that, I'm just throwing it out as a related
- Julian
|
This is an archived mail posted to the Subversion Dev mailing list.
This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.