[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Terminology (was: [PATCH 3/3] atomic-revprop: Signal the error as a HTTP status code)

From: Bert Huijben <bert_at_qqmail.nl>
Date: Mon, 20 Sep 2010 15:41:17 +0200

> -----Original Message-----
> From: 'Daniel Shahaf' [mailto:d.s_at_daniel.shahaf.name]
> Sent: maandag 20 september 2010 12:58
> To: Bert Huijben
> Cc: 'Jon Foster'; 'Subversion Development'
> Subject: Terminology (was: [PATCH 3/3] atomic-revprop: Signal the error
> as a HTTP status code)
>
> Bert Huijben wrote on Mon, Sep 20, 2010 at 12:17:12 +0200:
> > I think 'SVN_ERR_BAD_OLD_VALUE' could use a better/more generic name
> though.
> > ('Old value' is only valid in the specific function context. Maybe
> extend
> > this to something more like this 'precondition failed')
>
> In the interest of moving forward I've committed it already with its
> current macro name and default message, but we could rename the error
> code or the message in a followup commit.
>
> "Nominated value"? "Prevalue"? "BASE value"? "Entry value"?

I think the error should be in the SVN_ERR_RA (or if it originates there:
FS) prefix, not just 'SVN_ERR_BAD' and specify more what happened. (The BAD
category doesn't carry any information on what failed and is used only for
argument validation errors. This makes it hard to diagnose the error from
just the error code. And with our localized error messages that is all
applications that use libsvn_client can do)

So something like:
SVN_ERR_RA_PROP_BASEVALUE_MISMATCH
(specifies the RA problem)

Or just
SVN_ERR_RA_PRECONDITION_FAILED
(generic RA precondition problem)

        Bert
Received on 2010-09-20 15:43:17 CEST

This is an archived mail posted to the Subversion Dev mailing list.