[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: --with-neon broken on trunk since revision r984280?

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Sat, 14 Aug 2010 03:21:00 +0300

No issues here building svnsync or pristine-store-test.

Have you re-run autogen.sh?

Do you have any installed svn in $prefix? If so, can you remove that one
and try again?

Alexey Neyman wrote on Fri, Aug 13, 2010 at 16:38:55 -0700:
> Hi all,
>
> It looks like the revision r984280 broke the --with-neon configuration. I
> could compile r984212 with --with-neon, but r984280 gives:
>
> cd subversion/tests/libsvn_wc && /usr/share/apr-1.0/build/libtool --tag=CC --
> silent --mode=link gcc -g -O2 -pthread -D_LARGEFILE64_SOURCE -DNE_LFS -
> Werror=implicit-function-declaration -rpath /usr/local/svn-convert/lib -o
> pristine-store-test pristine-store-test.lo
> ../../../subversion/libsvn_client/libsvn_client-1.la
> ../../../subversion/tests/libsvn_test-1.la
> ../../../subversion/libsvn_wc/libsvn_wc-1.la
> ../../../subversion/libsvn_subr/libsvn_subr-1.la -laprutil-1 -lapr-1
> ../../../subversion/libsvn_client/.libs/libsvn_client-1.so: undefined
> reference to `svn_ra_open4'
> collect2: ld returned 1 exit status
> make: *** [subversion/tests/libsvn_wc/pristine-store-test] Error 1
>
> It compiles okay if I remove --with-neon option from configure. Is it
> expected?
>
> Regards,
> Alexey.
Received on 2010-08-14 02:23:39 CEST

This is an archived mail posted to the Subversion Dev mailing list.