On Fri, 2010-05-28 at 17:46 +0200, Stefan Sperling wrote:
> On Fri, May 28, 2010 at 02:47:23PM +0100, Julian Foad wrote:
> > The word "force" does not need to be part of the name, any more than we
> > need to write "--force-interactive" or "--force-non-recursive" or
> > "--force-revision=REV".
> > I would have thought "--diff-cmd=" would be a good UI for overriding a
> > config-file diff-cmd option.
> I'd prefer --internal-diff over --diff-cmd= because I believe people
> would look for a separate option rather than a special case of using
> --diff-cmd. It is also easier to document in the help output, and stands
> out better in the help output.
> > And, whatever the option is called, we will be introducing the same for
> > "svn diff", won't we?
> I think "svn diff" already has it.
As of yesterday, yes.
Received on 2010-05-28 18:55:17 CEST