[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: short alias for --force-internal-diff?

From: Stefan Sperling <stsp_at_elego.de>
Date: Fri, 28 May 2010 17:46:07 +0200

On Fri, May 28, 2010 at 02:47:23PM +0100, Julian Foad wrote:
> The word "force" does not need to be part of the name, any more than we
> need to write "--force-interactive" or "--force-non-recursive" or
> "--force-revision=REV".

+1

> I would have thought "--diff-cmd=" would be a good UI for overriding a
> config-file diff-cmd option.

I'd prefer --internal-diff over --diff-cmd= because I believe people
would look for a separate option rather than a special case of using
--diff-cmd. It is also easier to document in the help output, and stands
out better in the help output.
 
> And, whatever the option is called, we will be introducing the same for
> "svn diff", won't we?

I think "svn diff" already has it.

Stefan
Received on 2010-05-28 17:46:49 CEST

This is an archived mail posted to the Subversion Dev mailing list.