[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn_client_patch not applying patch correctly

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Sat, 22 May 2010 08:25:30 +0200

On 22.05.2010 00:58, Stefan Sperling wrote:
> On Fri, May 21, 2010 at 10:27:42PM +0200, Stefan Küng wrote:
>> * ShellCache.h
>> -> this file results in three applied and one rejected hunk
>> the result as it *should* be is shown in image1, the result
>> from svn_client_patch is shown in image2
> Where are the images you are referring to?

I've attached them to the email. It worked ok as I can see in my 'sent'
folder, but none of the archives of the mailing list seem to have it?
Attaching them again, maybe it works better this time.

> This seems to be a "no newline at end of file" handling problem.
> We should look at it in detail. Please file an issue.

I've also attached the images to the issue, just in case they vanish
again from this email.

>> * file1
>> -> this empty file should get one new line added, but instead
>> that hunk is rejected and the file stays empty.
> This is a bug in svn patch. Looks like it assumes the file will have content
> since it already exists (albeit it is empty). Please file a separate
> issue for this.



   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
Received on 2010-05-24 14:12:51 CEST

This is an archived mail posted to the Subversion Dev mailing list.