[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r941309 - /subversion/trunk/subversion/libsvn_client/commit_util.c

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: Wed, 05 May 2010 12:02:16 -0400

Philip Martin wrote:
> Greg Stein <gstein_at_gmail.com> writes:
>
>> On Wed, May 5, 2010 at 10:27, <philip_at_apache.org> wrote:
>>> ...
>>> +++ subversion/trunk/subversion/libsvn_client/commit_util.c Wed May 5 14:27:45 2010
>>> @@ -1036,7 +1036,7 @@ svn_client__harvest_committables(apr_has
>>> for (i = 0; i < targets->nelts; ++i)
>>> {
>>> const svn_wc_entry_t *entry;
>>> - const char *target_abspath;
>>> + const char *url, *target_abspath;
>>> svn_boolean_t is_added;
>>> svn_error_t *err;
>> Please use one line per variable declaration. Most code follows this
>> pattern, as it is easier to read (especially when initializers are
>> present).
>>
>> (and yes, we don't have a *rule* about this; I'm simply making a request)
>
> I don't see it as an improvement. Is there a consensus that one
> declaration per line is better?

No.

I prefer to put multiple items on a line as long as none of them is
initialized, especially if they can be logically grouped:

   const char *src_path, *dst_path;
   const svn_string_t *src_props, *dst_props;
   ...

That said, my life would almost certainly go on with only negligible
inconvenience if we adopted a one-var-per-line policy.

-- 
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on 2010-05-05 18:02:47 CEST

This is an archived mail posted to the Subversion Dev mailing list.