[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r941309 - /subversion/trunk/subversion/libsvn_client/commit_util.c

From: Philip Martin <philip.martin_at_wandisco.com>
Date: Wed, 05 May 2010 16:56:31 +0100

Greg Stein <gstein_at_gmail.com> writes:

> On Wed, May 5, 2010 at 10:27, <philip_at_apache.org> wrote:
>>...
>> +++ subversion/trunk/subversion/libsvn_client/commit_util.c Wed May  5 14:27:45 2010
>> @@ -1036,7 +1036,7 @@ svn_client__harvest_committables(apr_has
>>   for (i = 0; i < targets->nelts; ++i)
>>     {
>>       const svn_wc_entry_t *entry;
>> -      const char *target_abspath;
>> +      const char *url, *target_abspath;
>>       svn_boolean_t is_added;
>>       svn_error_t *err;
>
> Please use one line per variable declaration. Most code follows this
> pattern, as it is easier to read (especially when initializers are
> present).
>
> (and yes, we don't have a *rule* about this; I'm simply making a request)

I don't see it as an improvement. Is there a consensus that one
declaration per line is better?

-- 
Philip
Received on 2010-05-05 17:57:05 CEST

This is an archived mail posted to the Subversion Dev mailing list.