[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: '@BASE' vs. 'BASE tree' -- was: Re: svn_wc__db_base_get_info() vs. svn_wc__db_read_info() ?

From: Greg Stein <gstein_at_gmail.com>
Date: Sat, 30 Jan 2010 04:12:29 -0500

On Fri, Jan 29, 2010 at 06:59, Julian Foad <julianfoad_at_btopenworld.com> wrote:
> Neels J Hofmeyr wrote:
>> I'd call them the Unchanged tree, the Schedule tree, and the Actual tree.
>> And just to be wild, I'd not make them all-caps ;)
> For the first, "Unchanged" could be OK, although since we talk about
> changes so often it might be ambiguous in more contexts than some other
> words would be. ("If the Actual version is unchanged ...", "If the
> Unchanged version has changed ...") "Original" or "Repository" or
> "Checked out" might be better. "Base" might be OK if we decide that's
> what the meaning of the user-level "Base" concept should be.

I have no particular interest in ensuring the names line up, but I
definitely don't want to use the same name when it means something
else to our users.

"Repository" is troublesome because you might be talking about the
server-side trees. "Original", "Checked out", or "Pristine" seem okay.

> For the second, "Schedule" is a bad idea because it has strong and
> specific meanings in WC-1. Greg suggested "Restructured" which sounds
> perfect.
> For the third, "Actual" is fine.

Too busy to respond in depth here, but just had a thought: how about
"Edits" to replace the "Actual" name?

Received on 2010-01-30 10:13:04 CET

This is an archived mail posted to the Subversion Dev mailing list.