[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: '@BASE' vs. 'BASE tree' -- was: Re: svn_wc__db_base_get_info() vs. svn_wc__db_read_info() ?

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Fri, 29 Jan 2010 11:59:15 +0000

Neels J Hofmeyr wrote:
> I'd call them the Unchanged tree, the Schedule tree, and the Actual tree.
> And just to be wild, I'd not make them all-caps ;)

For the first, "Unchanged" could be OK, although since we talk about
changes so often it might be ambiguous in more contexts than some other
words would be. ("If the Actual version is unchanged ...", "If the
Unchanged version has changed ...") "Original" or "Repository" or
"Checked out" might be better. "Base" might be OK if we decide that's
what the meaning of the user-level "Base" concept should be.

For the second, "Schedule" is a bad idea because it has strong and
specific meanings in WC-1. Greg suggested "Restructured" which sounds

For the third, "Actual" is fine.

- Julian
Received on 2010-01-29 12:59:55 CET

This is an archived mail posted to the Subversion Dev mailing list.