[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: ruby test failure, 1.6.6 roll on hold (was Re: 1.6.6 on Oct. 14)

From: Hyrum K. Wright <hyrum_at_hyrumwright.org>
Date: Wed, 14 Oct 2009 13:54:57 -0500

On Oct 14, 2009, at 1:48 PM, Mark Phippard wrote:

> On Wed, Oct 14, 2009 at 2:32 PM, Hyrum K. Wright <hyrum_at_hyrumwright.org
> > wrote:
>> On Oct 12, 2009, at 11:28 AM, Hyrum K. Wright wrote:
>>
>>> On Oct 7, 2009, at 7:03 AM, Hyrum K. Wright wrote:
>>>
>>>> On Sep 28, 2009, at 1:20 PM, Hyrum K. Wright wrote:
>>>>
>>>>> It's that time again: time for another great-tasting release of
>>>>> Subversion! This one will be baked on Oct. 14 as Subversion
>>>>> 1.6.6.
>>>>> Get your nominations and votes in, to help make this the best
>>>>> release
>>>>> yet.
>>>>>
>>>>> [ Note to translators, et. al.: I'm not sure what time on Oct. 14
>>>>> the
>>>>> 1.6.6 tarball will roll, but you can safely assume that it will be
>>>>> after 0000 UTC. In other words, if your translations and other
>>>>> updates are on the branch by the end of the day on Oct. 13, you've
>>>>> nothing to fear about missing the deadline. The same applies for
>>>>> votes and nominations in STATUS. ]
>>>>
>>>> T minus 6.5 days, and counting.
>>>
>>> One more reminder: I'll be rolling 1.6.6 sometime after 0000 UTC on
>>> Oct. 14. It may be several hours later, but any changes approved in
>>> STATUS and translations on the 1.6.x branch are guaranteed to be in
>>> the release.
>>>
>>> Please nominate, review and vote on items in STATUS in the next
>>> couple
>>> of days.
>>
>> Getting ready to roll the tarball, I ran 'make check-swig-rb' on the
>> 1.6.x branch. I get the following segfault:
>>
>> test_merge(SvnClientTest): /home/hwright/dev/svn-1.6.x/subversion/
>> bindings/swig/ruby/test/my-assertions.rb:31: [BUG] Segmentation fault
>> ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]
>>
>> I'm planning on holding the roll until we determine the status of
>> this
>> bug.
>
> I am not getting this problem. But I did have a test failure. I do
> not know that this same failure did not also happen with other 1.6.x
> releases:
>
> Started
> ...............................................................................................F
> ...........................................................................................................................
> Finished in 535.915051 seconds.
>
> 1) Failure:
> test_mime_type_detect_with_type_map(SvnCoreTest)
> [/Users/mphippard/work/svn-1.6.x/subversion/bindings/swig/ruby/test/
> test_core.rb:631]:
> <Svn::Error::BadFilename> exception expected but none was thrown.
>
> 219 tests, 1483 assertions, 1 failures, 0 errors

Digging further, I see the following:

test_merge(SvnClientTest):
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fad06c586f0 (LWP 13356)]
0x00007fad0151cf46 in apr_hash_next (hi=0x1a01210) at tables/
apr_hash.c:128
128 hi->this = hi->ht->array[hi->index++];
(gdb) backtrace
#0 0x00007fad0151cf46 in apr_hash_next (hi=0x1a01210) at tables/
apr_hash.c:128
#1 0x00007fad051449c9 in c2r_hash_with_key_convert (hash=0x1a01200,
     key_conv=0x7fad05142edc <c2r_string>, key_ctx=0x0,
     value_conv=0x7fad05142c0f <svn_swig_rb_from_swig_type>,
     value_ctx=0x7fad053a5348)
     at subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c:
1409
#2 0x00007fad05144a7c in c2r_hash (hash=0x1a01200,
     value_conv=0x7fad05142c0f <svn_swig_rb_from_swig_type>,
ctx=0x7fad053a5348)
     at subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c:
1429
#3 0x00007fad05144ae8 in svn_swig_rb_apr_hash_to_hash_swig_type
(hash=0x1a01200,
     type_name=0x7fad053a5348 "svn_log_changed_path_t *")
     at subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c:
1447
#4 0x00007fad05364a00 in _wrap_svn_log_entry_t_changed_paths_get
(argc=0,
     argv=0x0, self=140381006173800) at subversion/bindings/swig/ruby/
core.c:5171
#5 0x00007fad06791c40 in rb_call0 (klass=140381119398840,
recv=140381006173800,
     id=16729, oid=16729, argc=0, argv=0x0, body=0x7fad06c131e8,
     flags=<value optimized out>) at eval.c:5904
#6 0x00007fad06791dfa in rb_call (klass=140381119398840,
recv=140381006173800,
     mid=16729, argc=0, argv=0x0, scope=0, self=140381005113880) at
eval.c:6151
#7 0x00007fad0678bcf0 in rb_eval (self=140381005113880, n=<value
optimized out>)
     at eval.c:3492
...

I can't reproduce this when running the test singly, though.

If others can't reproduce, I'll consider it an anomaly and continue to
roll.

-Hyrum

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2407696
Received on 2009-10-14 20:55:18 CEST

This is an archived mail posted to the Subversion Dev mailing list.