[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] libsvn_wc (log) #3, result_pool/scratch_pool

From: Greg Stein <gstein_at_gmail.com>
Date: Sat, 19 Sep 2009 13:40:43 -0400

On Sat, Sep 19, 2009 at 11:14, Martin Hauner <martin.hauner_at_gmx.net> wrote:
> I'll move on to adm_files.[ch] now if that is ok. Or is there anything more
> useful?

Much of that will become deprecated, so something like copy.c or
status.c would be another good place. But if you'd like to zing out
adm_files, that wouldn't be a problem!

> I have two questions regarding admin_files.[ch]:
> - svn_wc_get_adm_dir
> Reading the comment I think that it should have both (result/scratch) pools.
> Looking at the implementation it just returns a static. Is it worth here
> splitting the pool?

Nah. Just rename it to result_pool, and be done with it.

> - adm_files.[ch]
> In most cases there is no comment about the pool usage. Should I add it?

Not in adm_files.h, I'd think. Since they're internal functions, and
the two-pool paradigm is normal/expected, and half of those functions
will probably disappear... I'd say to not go out of your way to adjust
internal doc about dual pools.


Received on 2009-09-19 19:40:55 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.