[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svnadmin load will not import dump with windows newline character in svn:mergeinfo

From: Mark Phippard <markphip_at_gmail.com>
Date: Tue, 12 May 2009 12:35:52 -0400

On Tue, May 12, 2009 at 12:31 PM, Paul Burba <ptburba_at_gmail.com> wrote:
> On Mon, May 11, 2009 at 6:20 PM, Mark Phippard <markphip_at_gmail.com> wrote:
>> On Mon, May 11, 2009 at 5:01 PM, Paul Burba <ptburba_at_gmail.com> wrote:
>>
>>> Hi John - Do you know how the mergeinfo in r40998 was created?  Was it
>>> the result of a merge or a propset/propedit or something else
>>> entirely?  Also, can you hazard a guess as to what version of
>>> Subversion (or some other client tool) was used to make it?
>>>
>>> If possible I'd like to figure out how the <CR> got in your repository
>>> in the first place before making any fixes to dump/load.
>>
>> I am not sure why we are thinking this is anything special (related to
>> mergeinfo).  We have had many reports of people running into this
>> problem for all sorts of properties.
>
> Mark,
>
> I hadn't realized that, I see the various threads and issue #3404
> related to svnsync.  But dump/load with 1.6.2 works fine if there are
> "\r\n" in, say, an svn:log property...

Did you try it with svn:externals or any of the versioned properties?

I might have been combining svnsync problems with dump/load but I
thought we have seen it with both.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2217060
Received on 2009-05-12 18:36:11 CEST

This is an archived mail posted to the Subversion Dev mailing list.