[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Forcing the clients to upgrade to 1.5 or 1.6? Should we have "svn:minclientversion" property?

From: Geoff Rowell <geoff.rowell_at_gmail.com>
Date: Mon, 23 Mar 2009 17:59:52 -0400

Aleksey Nogin [mailto:anogin_at_hrl.com] wrote:
> When 1.5.0 was released, I realized that I would not be able to use the
> new svn:externals syntax until I have some way of making sure the
> connecting clients are all at least version 1.5. Now that 1.6.0 adds
> support for file externals I expect a similar problem.
>
> Unfortunately, subversion does not have (AFAIK) any mechanisms to
> explicitly tell the clients to upgrade. An 1.4 client encountering an
> svn:externals in 1.5 format would give an very unhelpful error message
> that would be completely baffling to a user who have not yet heard about
> the new 1.5 svn:externals format.
>

Hi Aleksey,

Look at the new "capabilities" input to the server's "start-commit" hook. If
the client-provided value doesn't include "mergeinfo", you know it's a
pre-1.5 client.

-Geoff

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1393264
Received on 2009-03-23 23:04:33 CET

This is an archived mail posted to the Subversion Dev mailing list.