[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Requiring Python 2.6 (was: Re: svn commit: r35458 - in branches/python-3-compatibility: . build subversion/bindings/swig subversion/tests/cmdline subversion/tests/cmdline/svntest tools/hook-scripts)

From: Branko Cibej <brane_at_xbc.nu>
Date: Sat, 21 Mar 2009 19:30:28 +0100

David James wrote:
> On Sun, Jan 25, 2009 at 11:25 AM, Arfrever Frehtes Taifersar Arahesis
> <Arfrever.FTA_at_gmail.com> wrote:
>
>> On the 'python-3-compatibility' branch:
>> Require Python >=2.6.
>> (Actually Python <2.6 wasn't supported earlier.)
>>
>
> Hi Arfrever,
>
> Is it possible to support Python 3.0 without breaking compatibility
> with Python 2.4? I know that a lot of people are still using Python
> 2.4, and I expect that this will still be the case when Subversion 1.7
> comes out. (In particular, Python 2.4 compatibility is important for
> the bindings, but I expect that folks will also want to be able to run
> the test suite and build system.)
>

Seconded. Unless you intend to merge this branch to trunk at least five
years from now.

-- Brane

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1374299
Received on 2009-03-21 19:30:46 CET

This is an archived mail posted to the Subversion Dev mailing list.