[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Requiring Python 2.6 (was: Re: svn commit: r35458 - in branches/python-3-compatibility: . build subversion/bindings/swig subversion/tests/cmdline subversion/tests/cmdline/svntest tools/hook-scripts)

From: David James <james82_at_gmail.com>
Date: Sat, 21 Mar 2009 10:04:36 -0700

On Sun, Jan 25, 2009 at 11:25 AM, Arfrever Frehtes Taifersar Arahesis
<Arfrever.FTA_at_gmail.com> wrote:
> On the 'python-3-compatibility' branch:
> Require Python >=2.6.
> (Actually Python <2.6 wasn't supported earlier.)

Hi Arfrever,

Is it possible to support Python 3.0 without breaking compatibility
with Python 2.4? I know that a lot of people are still using Python
2.4, and I expect that this will still be the case when Subversion 1.7
comes out. (In particular, Python 2.4 compatibility is important for
the bindings, but I expect that folks will also want to be able to run
the test suite and build system.)

Many users of Subversion use Red Hat Enterprise Linux, and upgrade to
new versions of RHEL about once every four years (when their version
of RHEL exits its "Production 1" phase). If users follow this
schedule, they will still be using Python 2.4 until at least March 31,
2011 (see http://www.redhat.com/security/updates/errata/).

Cheers,

David

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1373939
Received on 2009-03-21 18:04:51 CET

This is an archived mail posted to the Subversion Dev mailing list.