Currently INSTALL states that we require Python 2.2 or newer.
While trying to track down some testing bugs on Windows I downgraded
from Python 2.6.2 to 2.3.5 and, changing nothing else, re-ran the test
suite. The tests would not run to completion and hung in many places.
Then I tried to rebuild trunk (r35135) with 2.3.5 and the build
C:\SVN\src-trunk>gen-make.py -t vcproj --vsnet-version=2008
Found libdb47.lib in C:\SVN\bdb
Generating for VS.NET 2008
Could not detect Ruby version.
Ruby bindings will be linked with msvcrt-ruby18.lib
Found installed perl version number.
Perl bindings will be linked with perl510.lib
Found installed SWIG version 1.3.36
Using SWIG library directory C:\SVN\swig\Lib
Found JDK version 1.6 in C:\Program Files\Java\jdk1.6.0_07
Found SQLite version 3.6.3
Found neon version 0.28.2
Traceback (most recent call last):
File "C:\SVN\src-trunk\gen-make.py", line 288, in ?
main(conf, gentype, skip_depends=skip, other_options=rest.list)
File "C:\SVN\src-trunk\gen-make.py", line 40, in main
generator = gen_module.Generator(fname, verfname, other_options)
File "build\generator\gen_vcnet_vcproj.py", line 18, in __init__
File "build\generator\gen_win.py", line 285, in __init__
File "build\generator\swig\header_wrappers.py", line 20, in __init__
generator.swig.Generator.__init__(self, conf, swig_path)
File "build\generator\swig\__init__.py", line 43, in __init__
self.swig_libdir = _exec.output([self.swig_path, "-swiglib"], strip=1)
File "build\generator\util\executable.py", line 44, in output
(stdin, stdout) = os.popen4(cmd)
TypeError: popen4() argument 1 must be string, not list
Now this build problem is simple to fix, but it, and the testing
failures, make me wonder if any active developers are using "older"
versions of Python. Perhaps it is time we bumped the minimum
I suggest 2.4 because there are several places in the build and test
environment where different code paths are followed for Python < 2.4
and from my preliminary testing these code paths don't work correctly.
So either we need to fix them or remove them.
Any objections to bumping the minimum version? If not, should it be
2.4 or something even newer?
Received on 2009-01-09 23:30:10 CET