[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SQLite and the Ruby bindings tests on Windows

From: Kouhei Sutou <kou_at_cozmixng.org>
Date: Wed, 17 Dec 2008 21:59:15 +0900 (JST)

Hi,

In <ae6cb1100812162228l55b5270am768b169e8aa15bcd_at_mail.gmail.com>
  "Re: SQLite and the Ruby bindings tests on Windows" on Tue, 16 Dec 2008 22:28:04 -0800,
  "Joe Swatosh" <joe.swatosh_at_gmail.com> wrote:

> >>> > What about adding Svn::Client::Context#close and
> >>> > Svn::Client::Context#initialize accepts a block?
> >>> >
> >>> > pseudo code:
> >>> > class Svn::Client::Context
> >>> > def initialize(...)
> >>> > ...
> >>> > return unless block_given?
> >>> > begin
> >>> > yield(self)
> >>> > ensure
> >>> > close
> >>> > end
> >>> > end
> >>> >
> >>> > def close
> >>> > @pool.destroy
> >>> > end
> >>> > end
> >>> >
> >>> > But I'm not sure that 'close' is a good name for that...
> >>> >
> >>>
> >>> Based on the above idea, I committed r34708. Instead of Context#initialize
> >>> taking a block I modified SvnTestUtil#make_context to take a block. I think
> >>> that worked better for updating the tests, but I'd like to see the
> >>> Context#initialize take a block someday.
> >>
> >> I think of an idea that 'destroy' is more better name rather
> >> than 'close'. What about this? The attached patch includes
> >> block supported #initialize.

> So it looks pretty good. We have the merge tests and test_relocate in

Thanks for confirming my patch. I've committed it.

Thanks,

--
kou
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=985675
Received on 2008-12-17 14:00:11 CET

This is an archived mail posted to the Subversion Dev mailing list.