[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] [PATCH] Raise minimal required version of Neon to 0.27

From: Senthil Kumaran S <senthil_at_collab.net>
Date: Wed, 10 Sep 2008 12:01:46 +0530

Hash: SHA1

Stefan Sperling wrote:
> It's nice when things still work on old boxes.
> I'd argue not removing existing support for third party software
> from Subversion unless:
> 1) It obviously becomes too much of a maintenance burden for some reason.
> 2) We need to upgrade the dependencies because old versions don't
> have required features.
> We should not force our users into dependency hell for no good reasons.

I perfectly agree with this. If we have neon 0.23 working with subversion
1.5/1.6 (with all the features required from neon) then we need to have some
mechanism which says neon 0.23 or greater is supported. We should not restrict
the user by saying the supported versions of neon are 0.xx, 0.xy only, ie.,
restricting the user with 0.27 and 0.28 or something like that. IMHO, this
helps the user to compile subversion with whatever old dependencies they have
(of course which works well).

Thank You.
- --
Senthil Kumaran S
Version: GnuPG v1.4.6 (GNU/Linux)


To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-09-10 08:32:05 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.