[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] [PATCH] Raise minimal required version of Neon to 0.27

From: Arfrever Frehtes Taifersar Arahesis <arfrever.fta_at_gmail.com>
Date: Mon, 8 Sep 2008 15:30:37 +0200

2008-09-08 00:14:46 Blair Zajac napisał(a):
> Arfrever Frehtes Taifersar Arahesis wrote:
> > 2008-09-07 03:52:40 Blair Zajac napisał(a):
> >> Arfrever Frehtes Taifersar Arahesis wrote:
> >>> I would like to suggest to raise minimal required version of Neon to 0.27.
> >>> When Subversion 1.6 is released, Neon 0.26 will be very old and rather
> >>> nobody will try to use Subversion 1.6 with such old versions of Neon.
> >>> (r21480 removed support for Neon 0.24.)
> >> I don't see the urgency in removing code
> >
> > OK. So what do you think about removing support only for Neon 0.25?
> > Neon 0.26.0 was released about 30 months ago.
> >
> > r21480 removed support for Neon 0.24 about 17 months after the release of
> > Neon 0.25.0.
> >
> >> recent bump to Python 2.4
> Sorry, should have been more clear. Python 2.4 for some of our scripts and tool.
> Taking a step back, I don't see why we need to update any of the dependencies
> that you've supplied patches for:
> 1) Bash

I didn't know that old versions of BASH don't support '+='.

> 2) Python

Fortunately there is a sufficient reason to update Python dependency:

Calls to os.popen* and popen2.* cause deprecation warnings.
These calls should be replaced with appropriate calls to subprocess.*.

For example, running autogen.sh causes deprecation warning in

$ ./autogen.sh
buildcheck: checking installation...
buildcheck: autoconf version 2.62 (ok)
buildcheck: autoheader version 2.62 (ok)
buildcheck: libtool version 2.2.4 (ok)
Copying libtool helper: /usr/share/aclocal/libtool.m4
Copying libtool helper: /usr/share/aclocal/ltoptions.m4
Copying libtool helper: /usr/share/aclocal/ltsugar.m4
Copying libtool helper: /usr/share/aclocal/ltversion.m4
Copying libtool helper: /usr/share/aclocal/lt~obsolete.m4
Creating build-outputs.mk...
build/generator/util/executable.py:28: DeprecationWarning: os.popen4 is deprecated. Use the subprocess module.
  stdin, stdout = os.popen4(cmd)
Creating svn_private_config.h.in...
Creating configure...

You can run ./configure now.

Running autogen.sh implies you are a maintainer. You may prefer
to run configure in one of the following ways:

./configure --enable-maintainer-mode
./configure --disable-shared
./configure --enable-maintainer-mode --disable-shared

Note: If you wish to run a Subversion HTTP server, you will need
Apache 2.x. See the INSTALL file for details.


subprocess module [1] is available in Python >=2.4.
subprocess module has also several other advantages.

[1] http://docs.python.org/dev/library/subprocess.html

Arfrever Frehtes Taifersar Arahesis

Received on 2008-09-08 15:34:05 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.