[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r31583 - trunk/subversion/libsvn_wc

From: Branko ─îibej <brane_at_xbc.nu>
Date: Wed, 04 Jun 2008 23:23:21 +0200

Karl Fogel wrote:
> Gently enforcing stylistic consistency is a perfectly reasonable thing
> for a project to do.

Yes. Changing the coding style in a trivial way that doesn't actually
improve readability for most people isn't reasonable.

We did this once with the space-before-paren thing, though that had
somewhat stronger arguments on its side because most people (who weren't
used to RMS's creative destructivism) were a bit put off by the code.

Changing the spots on the bikeshed from mauve to lavender won't make a
noticeable difference except that the other half of developers are going
to be unhappy. :(

I'd suggest to leave well enough alone, and let people write '!strcmp()
or '! strcmp()' or '0 == strcmp()' or 'strcmp() == 0' or '!strcmp() !=
0' or whatever suits them as long as the meaning is obvious and the code
is correct.

-- Brane

To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-06-04 23:24:07 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.