[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: A concern about mergeinfo and compatability.

From: Karl Fogel <kfogel_at_red-bean.com>
Date: Wed, 30 Jan 2008 09:28:15 -0500

"C. Michael Pilato" <cmpilato_at_collab.net> writes:
> Also, we did *not* involve the repository version number in our
> capabilities checks. See
> libsvn_ra_local/ra_plugin.c:svn_ra_local__has_capability() and
> mod_dav_svn/version.c:get_vsn_options(), for example.

Queries should be about capabilities, not about version numbers.
Don't ask "What repository version are you?", instead ask "Do you
support the XYZ capability I'd like to use?"

(I.e., the same philosophy autoconf uses.)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-01-30 15:35:01 CET

This is an archived mail posted to the Subversion Dev mailing list.