[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: naming issue: SVN_FS_PROP_TXN_*

From: David Glasser <glasser_at_davidglasser.net>
Date: 2007-09-20 01:41:31 CEST

On 9/19/07, Malcolm Rowe <malcolm-svn-dev@farside.org.uk> wrote:
> On Wed, Sep 19, 2007 at 11:26:20AM -0700, David Glasser wrote:
> > Three property names are defined in libsvn_fs/fs-loader.h starting
> >
> > Shouldn't they be SVN_FS__PROP_TXN_*?
> >
> No, I think the first two are part of a public API, though I haven't
> time to check just now.

But they're defined in libsvn_fs/fs-loader.h... There's
SVN_FS_TXN_CHECK_OOD and SVN_FS_TXN_CHECK_LOCKS in svn_fs.h but that
is different (bits instead of prop names).

> > (Also, I don't think contains-mergeinfo is necessary: it's only used
> (agreed).
> > by FSFS, and you should be able to just see if the mergeinfo file
> > exists on disk instead, no?)
> >
> Sure. I'd actually like to move the mergeinfo information -- currently
> stored in a 'mergeinfo transaction property' file -- into the
> already-existing transaction properties hash (since I see no reason why
> we need a separate file). So we'd need to read that instead, but sure.

I guess arguably there's some efficiency argument being made that you
only have to read and dump the mergeinfo each time a path is added
during the transaction build phase, instead of the whole txnprops hash
(log message, etc). Of course the hash build is already quadratic...


David Glasser | glasser_at_davidglasser.net | http://www.davidglasser.net/
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Sep 20 01:41:41 2007

This is an archived mail posted to the Subversion Dev mailing list.