[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Update dependencies tarball for 1.5 release

From: Mark Phippard <markphip_at_gmail.com>
Date: 2007-09-10 19:50:03 CEST

There was a brief discussion on IRC last week where a user was using
APR 0.9.12 and Sussman wondered why any new user would not just use
1.2.x from the start. One reason is that our dependencies tarball
includes 0.9.x.

Should we change this for the 1.5 release? I believe the binary
dependency issue has been raised in the past for a reason to not do
this, but wouldn't the people most likely be to affected by this
problem be using an APR from their distro?

The next one is Neon. One of the 1.5 milestone issues is 2807: win32
client segfault with SSPI / Kerberos over HTTPS.

Based on the issue, it sounds like we just need to be using 0.26.4+ of
Neon to resolve this problem. Should we update our version of Neon in
the dependencies to this version?

One way or the other, I think if DJ just updates his build system we
can close that issue.

It seems like we have a lot more to gain than lose by updating our
default dependencies.

Mark Phippard
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Sep 10 19:46:45 2007

This is an archived mail posted to the Subversion Dev mailing list.