[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Remove APR ICONV dependency on Windows (was SVN Win32 Developers -- need some help)

From: D.J. Heap <djheap_at_gmail.com>
Date: 2007-07-08 03:32:05 CEST

On 7/7/07, Ivan Zhakov <chemodax@gmail.com> wrote:
[snip]
> Is it happens only with 'Debug' build, but doesn't happen with 'Release'?

It fails quite consistently with Release, somewhat sporadically with Debug.

>
> May be there are some problems with DLLs? Did you try to build with
> --disable-shared? Another source of problems may be that there are
> different APR libraries installed somewhere.

Haven't tried --disable-shared (the fs-test.exe is statically linked
anyway), but I'm fairly certain the APR libraries are the correct ones
-- while debugging I watched which ones were loaded.

>
> Also could you check how is your APR built: Is it built with
> APR_HAS_UNICODE_FS or not?

Yes it is.

>
> Do you have some antivirus software installed?

No.

I will back out the patch and see what happens...The buildbot had been
running pretty clean up until that day, as I recall, though -- and I
got the same failures on a different VM with the VC6 build as well.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Jul 8 03:31:59 2007

This is an archived mail posted to the Subversion Dev mailing list.