[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Remove APR ICONV dependency on Windows (was SVN Win32 Developers -- need some help)

From: D.J. Heap <djheap_at_gmail.com>
Date: 2007-07-07 17:31:40 CEST

On 7/5/07, Ivan Zhakov <chemodax@gmail.com> wrote:
[snip]
> > svn_tests: Reference to non-existent node
> > '1.0.tDJ-VM-XP-VS6-02704-1183257584562500-1' in filesystem
> > 'test-repo-check-root-revision'
> > FAIL: fs-test.exe 26: ensure accurate storage of root node
[snip]
> I committed my patch and found that these tests fails on your buildbot
> slave even with VS2005. But they work on my computer. Could you see
> what happens on your buildbot slave?

I've spent a few hours trying to debug through this now and haven't
found out exactly what is going on. It doesn't happen when I step
through the code with a debugger, and it is somewhat sporadic in the
debug build anyway. So I've had to put in sleeps, printf traces, etc.
to get anywhere and those sometimes stop the failure from happening as
well.

But in all the failures I've seen, it comes down to a transaction
child-node file not being there -- whether it was never created or has
been deleted or something, I'm not sure yet. Any ideas or suggestions
on where to look or what to look for?

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Jul 7 17:31:25 2007

This is an archived mail posted to the Subversion Dev mailing list.