[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svn_wc_ventry(_ex) to eliminate heavily repeated code

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2007-03-19 22:19:09 CET

On 3/17/07, Malcolm Rowe <malcolm-svn-dev@farside.org.uk> wrote:
> On Sat, Mar 17, 2007 at 12:14:21AM +0100, Erik Huelsmann wrote:
> > The function svn_wc_ventry_ex (ventry as for 'valid entry') which
> > takes a file name and a line number. The macro svn_wc_ventry()
> > forwards to the function, adding the filename and lineno.
> >
> > I know it isn't our usual pattern, but it's one of the ways I see to
> > make libsvn_wc a bit more readable.
> >
> > BTW: This patch has 2 failing tests, because of changed error output.
> > No real problems, as far as I can tell.
> >
> I like this approach, although I wonder whether it's appropriate to
> consolidate the existing error messages into one "%s is not under version
> control" messages?
> I'd also prefer a more explicit function name: when I saw it first, I
> guessed 'ventry' meant 'valid' or 'virtual' (or 'ventricle'). Perhaps
> 'svn_wc_entry_versioned()', making it clearly a variant of svn_wc_entry()?

Ok. I did that.

As far as the first remark is concerned, I'm looking back at the
adjusted patch and I'm wondering: What *is* the difference between 'No
entry found' and "'%s' is unversioned"? Some errors have the 'no entry
found' (which is also a different result code!) but I can't for the
life of me figure out why we would have different result codes for
these situations, especially because they're detected by the same

Anybody any ideas?



To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Mar 19 22:19:23 2007

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.