On Sat, Mar 17, 2007 at 12:14:21AM +0100, Erik Huelsmann wrote:
> The function svn_wc_ventry_ex (ventry as for 'valid entry') which
> takes a file name and a line number. The macro svn_wc_ventry()
> forwards to the function, adding the filename and lineno.
> I know it isn't our usual pattern, but it's one of the ways I see to
> make libsvn_wc a bit more readable.
> BTW: This patch has 2 failing tests, because of changed error output.
> No real problems, as far as I can tell.
I like this approach, although I wonder whether it's appropriate to
consolidate the existing error messages into one "%s is not under version
I'd also prefer a more explicit function name: when I saw it first, I
guessed 'ventry' meant 'valid' or 'virtual' (or 'ventricle'). Perhaps
'svn_wc_entry_versioned()', making it clearly a variant of svn_wc_entry()?
Received on Sat Mar 17 12:15:35 2007
- application/pgp-signature attachment: stored