[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Can I run the 1.5 client on a 1.4.3 installation?

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2007-03-03 10:55:22 CET

On 3/3/07, svn.dev@salvisberg.com <svn.dev@salvisberg.com> wrote:
> The 1.5 client has a bug fix that I need. What is the risk of running the 1.5 client on a 1.4.3 installation, as long as I only use 1.4 commands?

Can't we help you by backporting the fix and release it in a next 1.4
release? What fix are you talking about?

If not: assuming you'll replace the libraries on your system with the
1.5-dev ones, all applications should keep working: the libraries are
backward compatible (ie provide all the same entry points as earlier
versions).

When you decide to build applications against 1.5-dev and you update
to a newer 1.5-dev, you run the risk that entry points have their
signatures changed iff they were added in the 1.5 cycle. That's
basically all.

I must stress however that you'll also get any bugs that have been
introduced since 1.4 and will be fixed before 1.5-final. I hope you're
aware of that risk.

bye,

Erik.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Mar 3 10:55:38 2007

This is an archived mail posted to the Subversion Dev mailing list.