On Wed, Feb 14, 2007 at 02:15:12PM -0800, Daniel Rall wrote:
> > On Wed, Feb 14, 2007 at 09:55:22AM -0800, Daniel Rall wrote:
> > > > But if we think that the API is generally useful, let's keep it (I'm
> > > > not convinced myself, though :-)).
> > >
> > > I do find the new API useful along the lines of 'rm' vs. 'rm -f'.
> > > It's a rather common situation in programming that the target of a
> > > deletion may not exist; having a shorthand to handle this situation is
> > > certainly not required, but is a nice convenience. *shrug*
> > >
> > I did notice that we decided not to do that for svn_io_remove_file()
> > though. But like you said, *shrug*.
> I think they should be consistent. I can either:
> a) Introduce a svn_io_remove_file2() along the lines of svn_io_remove_dir2().
> b) Revert the "remove_dir" version, and use your suggested approach
> for both.
I think we should definitely do one of the above, and I think you know
that my preference was for the latter :-) But I'd be interested to hear
what other people think.
> p.s. Feel free to add dev@ back to the CC list.
Received on Mon Feb 19 21:03:25 2007
- application/pgp-signature attachment: stored