[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r23366 - trunk/subversion/libsvn_subr

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: 2007-02-07 22:45:32 CET

Malcolm Rowe wrote:
> On Wed, Feb 07, 2007 at 09:41:05AM -0800, cmpilato@tigris.org wrote:
>> * subversion/libsvn_subr/path.c
>> (svn_path_splitext): Rename variable 'last_period' to 'last_dot'.
>> No logic changes.
> The comments all still say 'period'.

Yeah. Doesn't bother me so much.

> What was the rationale behind this, by the way?

Code churn?

Seriously, the "_period" naming had been bugging me anyway because my mind
kept associating "last period" with the final third of a hockey game or
something, and using a shorter name allowed me to not have to line-wrap a
bit of arithmetic.

C. Michael Pilato <cmpilato@collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on Wed Feb 7 22:45:43 2007

This is an archived mail posted to the Subversion Dev mailing list.