[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] renaming the function as per convention

From: Malcolm Rowe <malcolm-svn-dev_at_farside.org.uk>
Date: 2006-08-28 13:21:52 CEST

On Mon, Aug 28, 2006 at 01:57:32PM +0530, Kamesh Jayachandran wrote:
> static function is not supposed to have 'svn_' prefix.
> We use '__' in function names that is used by other 'C' files
> within the same library.
> * subversion/libsvn_diff/diff4.c
> (svn_diff__adjust): Renamed to _diff_adjust.
> (svn_diff_diff4): Calls _diff_adjust.

I don't think we use leading underscores anywhere else; why not
'diff_adjust' (or even 'adjust_diff', since that presumably is a better
description of what it's doing).

> static APR_INLINE void
> -svn_diff__adjust(svn_diff_t *diff, svn_diff_t *adjust)
> +_diff_adjust(svn_diff_t *diff, svn_diff_t *adjust)
> {

Incidentally, isn't this function a bit large to be inlined?


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Aug 28 13:22:24 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.