[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Infrastructure changes for incomplete directory support.

From: Karl Fogel <kfogel_at_google.com>
Date: 2006-08-10 01:00:01 CEST

"Garrett Rooney" <rooneg@electricjellyfish.net> writes:
> On 8/8/06, Karl Fogel <kfogel@google.com> wrote:
>> +/** The WebDAV concept of "depth".
>> + * @since New in 1.5.
>> + */
> Any reason to specifically refer to it as 'The WebDAV concept", it's
> not like it's limited to use in the DAV layer...

That's just the only place I've consistently heard it used before, and
also it's how at least one place in our codebase referred to this
concept before now (you can see that place in the diff).

>> +typedef enum
>> +{
>> + svn_depth_exclude = -1, /* Exclude (remove, whatever) directory D. */
> I don't notice any use of this one in the rest of the patch...

It's not used in this patch, right. I think we'll need it for some
later functionality, though.

> It occurs to me here while reading the serialization/deserialization
> code that maybe it would be nice to have names other than "zero" or
> "one", since unless you already know what those mean they don't really
> describe much to you. They also look like any other line in the
> entries file, which is already somewhat hard to read. Might be nice
> if they stood out more...
> I don't actually have any ideas, mind you, but in the "it would be
> nice" category...


See earlier mail. I'm coming up, uh, zero on better names, but would
be happy to change to better names if we think of some.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Aug 10 01:01:11 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.