Perhaps the parameter should be renamed instead? We usually refer to
its type of data as "copyfrom", as opposed to just "copy".
On Sat, 29 Jul 2006, Madan S. wrote:
> While looking at the svn_delta_editor_t structure, I found that the API
> doc for the add_file() member referred to parameter names that were not
> part of the add_file() prototype. Maybe these parameters were renamed
> sometime later? Anyways, pl. find attached a patch that fixes this doc and
> the corresponding log.
> Index: subversion/include/svn_delta.h
> --- subversion/include/svn_delta.h (revision 20891)
> +++ subversion/include/svn_delta.h (working copy)
> @@ -800,9 +800,9 @@
> * store a baton for this new file in @a **file_baton; whatever value
> * it stores there should be passed through to @c apply_textdelta.
> - * If @a copyfrom_path is non-@c NULL, this add has history (i.e., is a
> + * If @a copy_path is non-@c NULL, this add has history (i.e., is a
> * copy), and the origin of the copy may be recorded as
> - * @a copyfrom_path under @a copyfrom_revision.
> + * @a copy_path under @a copy_revision.
> * Allocations for the returned @a file_baton should be performed in
> * @a file_pool. It is also typical to save this pool for later usage
> Correct parameter references in the API doc.
> * subversion/include/svn_delta.h
> (svn_delta_editor_t.add_file): Correct doc to refer to copy_path and
> copy_revision instead of copyfrom_path and copyfrom_revision.
Received on Fri Jul 28 23:11:17 2006
- application/pgp-signature attachment: stored