[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r19915 - trunk

From: Max Bowsher <maxb1_at_ukf.net>
Date: 2006-06-03 18:12:15 CEST

Erik Huelsmann wrote:
>> Log:
>> Require APR 0.9.7, since it detects error while writing to buffered
>> files.
>>
>> Older APR versions don't. It seems like the only way we can assure
>> correct
>> file writes in FSFS repositories.
>>
>> * configure.in (APR_VER_REGEXES,
>> APU_VER_REGEXES): Increase minimum version to 0.9.7.
>
> I have proposed this change for backport to 1.4.x, but shouldn't it be
> backported to all branches that have FSFS as their default repository,
> or even to all branches which include FSFS period? I mean, it may
> (rarely) cause dataloss or at least data integrity problems...

It certainly ought to go into 1.3.x.

It seems highly unlikely that we would release another 1.2.x, though.

Max.

Received on Sat Jun 3 18:12:44 2006

This is an archived mail posted to the Subversion Dev mailing list.