[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.3.1 tarballs up for testing/signing (Again)

From: Jani Averbach <jaa_at_jaa.iki.fi>
Date: 2006-03-31 15:35:15 CEST

On 2006-03-31 12:24+0200, Branko ??ibej wrote:
> Ivan Zhakov wrote:
> >On 3/30/06, Branko ??ibej <brane@xbc.nu> wrote:
> >
> >>Well, I can't sign the 1.3.1 Windows ZIP file. Testing on my 2xAthlon MP
> >>box, 5 combinations pass, but I see random deadlocks during the svnserve
> >>+ bdb.tests. I haven't been able to determine what's going on, though.
> >>Both svnserve.exe and svn.exe seem to be idle, not waiting for anybody ...
> >>
> >Did you try bdb on miltiprocessor machine? It seems bdb have bugs on
> >multiproccessor machine: when I was setting up my company server on
> >Debian with multiproccessor kernel it was dead locking after less than
> >day usage. So I asked admins to remove second proccessor and now
> >everything is ok.
> >
> Yes, a 2xAthlon MP box has two processors. :)
> But this is Windows, not Linux; and the local and ra_dav tests had no
> problems whatsoever with BDB.

I have had cases (with 1.3.0-rcX) when ra_svn + bdb tests were failing
without no obvious reason. Restarting the test setup fixed them.
This happened with Linux on dual Opteron system. After that, I haven't
seen those errors anymore.

BR, Jani

-- 
Jani Averbach
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Mar 31 15:37:34 2006

This is an archived mail posted to the Subversion Dev mailing list.