[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.3.1 tarballs up for testing/signing (Again)

From: eg <egoots_at_gmail.com>
Date: 2006-03-31 09:41:28 CEST

Branko Čibej wrote:

>> Well, I can't sign the 1.3.1 Windows ZIP file. Testing on my 2xAthlon
>> MP box, 5 combinations pass, but I see random deadlocks during the
>> svnserve + bdb.tests. I haven't been able to determine what's going
>> on, though. Both svnserve.exe and svn.exe seem to be idle, not waiting
>> for anybody ...
>>
>> Yes, I am running an antivirus scanner on my box, but I disabled it
>> for this test, and nothing changed.
>>
>> Most weird.
> Heh. I may not be smart enough to figure it out, but persistence pays
> off -- if the tests fail, repeat them until they pass. And here's proof
> that Windows is nothing but a heisenbug. :)
>
> Tested the .zip flle 6 ways on Windows (httpd-2.0.54, neon-0.25.5), all
> tests pass.
>

Does the BDB code have any multi-threaded code?
It sure screams out as a synchronization bug in the software... these
always show up faster in multi-processor systems... and they may not be
100% repeatable in a short test sequence.

Isn't it too easy to ignore this error as a Windows flakiness issue;
especially when others have seen it intermittently?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Mar 31 09:41:59 2006

This is an archived mail posted to the Subversion Dev mailing list.