[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: vfat mount and subversion

From: Branko Čibej <brane_at_xbc.nu>
Date: 2006-03-19 21:21:17 CET

Ilpo Järvinen wrote:
> Hello,
>
> I have encountered couple of problems on a laptop which has a vfat mounted
> for sharing between Linux and XP. I'm not sure whether this has been
> reported earlier (I searched for vfat but nothing came up). And I also
> quickly scanned through the fixes made in 1.3.0 and and 1.3.1 but couldn't
> find any reference.
>
> ijjarvin@kivilampi-30:~$ svn --version
> svn, version 1.2.3 (r15833)
> compiled Aug 26 2005, 03:42:45
>
> Because vfat does not have standard chmoding capabilities,
Which we don't use anyway.
> some commands
> fail:
>
> - svn update fails (Might also be due to international character ö or
> spaces in the filename)
> After that, it asks me to do svn cleanup, but
> - svn cleanup fails (cannot set some files to readonly)
>
Note that the client won't work reliably on FAT because of it's
two-second modification time granulation.

> Other thing I have so far had no luck is:
>
> - svn commit to repository that resides on the vfat drive (as it cannot
> set some permissions?)
>
What kind of repository? What kind of problems? Can you post a
transcript of what you're doing?

> Other commands could be affected as well... Should I file a issue from
> these?
>
Please describe the problems you see in more detail here first.

-- Brane

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Mar 19 21:23:46 2006

This is an archived mail posted to the Subversion Dev mailing list.