[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Diff --old --new: too many peg revision specifiers

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2006-03-16 01:44:07 CET

kfogel@collab.net wrote:
> Julian Foad <julianfoad@btopenworld.com> writes:
>
>>Patch attached. OK so far?
>
> Looks like a sensible step to me, & the patch looks good (I haven't
> applied it, but reviewed it in-place).
>
> Note that no backporting to 1.4.x is required, since it's just trunk.

Oh, good - silly me, I'd seen Dave Anderson's announcement that he was
branching 1.3.1 a few days ago and had interpreted it as "1.4" in my head.

>>Next step: I think we shouldn't drop support for "-r" before v2, but I
>>think it is OK for us to deprecate an aspect of the User Interface in
>>a minor release just as we deprecate APIs. I propose to remove the
>>mention of "-r" from the main description, and add a note stating it
>>is accepted for backward compatibility, and describing its meaning.
>
> +1

I'll prepare a patch.

- Julian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Mar 16 01:44:23 2006

This is an archived mail posted to the Subversion Dev mailing list.