[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r17521 - trunk/subversion/clients/cmdline

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2005-11-26 20:45:59 CET

Malcolm Rowe wrote:
> On Sat, Nov 26, 2005 at 11:19:27AM -0600, julianfoad@tigris.org wrote:
>
>>* subversion/clients/cmdline/main.c
>> (svn_cl__cmd_table): Modify help text for pdel, pedit, pget, plist, pset:
>> Use plural "props" in "propget", as in the other commands.
>
> The use of 'prop' vs 'props' is still inconsistent after this change:
>
>> " 1. Removes versioned props in working copy.\n"
>>+ " 2. Removes unversioned remote prop on repos revision.\n"
>>
>> " 1. Edits versioned props in working copy.\n"
>>+ " 2. Edits unversioned remote prop on repos revision.\n"
>>
>>+ " 1. Prints versioned props. If specified, REV determines in which\n"
>> " 2. Prints unversioned remote prop on repos revision.\n"

Only inconsistent in the intended way, unless I'm missing something. The (1)
versions can operate on multiple properties (same prop name on different items)
whereas the (2) versions can only operate on a single (revision) property.

> In general, the summary of the command is in the imperative ("Remove a
> property"), while the detailed descriptions vary in their generality:

The summaries of all commands are (I believe) consistently imperative.

> 1. [This function generally] Removes versioned props in working copy.
> 2. [This function, when used, ] Removes [an] unversioned remove prop on...

No, both (1) and (2) mean "When used"; that's a result of your misunderstanding
above, I think.

> We need to work out if we're describing what the function does in general,
> or documenting what it does specifically (and shouldn't that preposition
> be 'from' in both cases, btw?)

The detailed descriptions describe what it does specifically, though I'll admit
they aren't all very good. OK, not many of them are very good. But they're
not too bad either.

Yes, "from" would be better in the case of "remove". I'll keep it in mind for
when I make some tweaks.

- Julian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Nov 26 20:46:40 2005

This is an archived mail posted to the Subversion Dev mailing list.