[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Supporting APR 0.9.4

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2005-11-26 20:27:04 CET

For a long time now, we don't support APR 0.9.4. The RHEL 3 package
has patched our configure to make Subversion compile with it (because
it's the system default). Our INSTALL says we require APR 0.9.7, but
configure allows 0.9.5.

After I recently removed some code to support pre-0.9.5 APR versions,
David Summers claims the build for RHEL3 was suddenly broken. I'd
like to dispute that since he can't compile an unpatched Subversion on
RHEL3 since way before 1.0.

I'm not against David providing RHEL3 packages - on the contrary! I
think it's a good thing - but since it's his patching which makes it
work, I hold the position could easily add another patch which
reverses the 'remove-compat-code'-commits.

In other words: Can we please either have configure accept 0.9.4,
making our support for it official, or can I please remove code which
doesn't apply to supported versions, making it completely unsupported?

I'd like opinions on the above.

bye,

Erik.
Received on Sat Nov 26 20:27:48 2005

This is an archived mail posted to the Subversion Dev mailing list.