[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] add 'svn version' as 'svnversion' v1

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: 2005-11-03 15:09:07 CET

Fabien COELHO <fabien@coelho.net> writes:

> Dear Branko,
> >> Yes, if we are going to do this, we should *definitely* take the
> >> opportunity to choose a better name.
> > Before going on with this patch, I'd like to see some real
> > discussion about why we want this in svn proper at all. What's wrong
> > with leaving the functionality in svnversion? I've not seen a single
> > good reason.
> I'm still waiting for a good reason to have it a separate command.
> *ALL* other user accesses are managed with "svn" and its
> subcommands.

Suggestion: See how that other thread about allowing second-class
utilities ("[RFC] 'basic/additional command set' - adding svn
subcommands without destroying our learning curve") into the 'svn'
binary pans out, and if folks are cool with it, add 'svn versions' as
a second-class utility command. Yes, I meant to say "versionS",
plural, because I'm -1 on 'svn version' -- it's just too similar to
'svn --version', and it can return a revision range and other
annotations, too.

C. Michael Pilato <cmpilato@collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Nov 3 15:11:17 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.