[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] add 'svn version' as 'svnversion' v1

From: Max Bowsher <maxb_at_ukf.net>
Date: 2005-11-02 14:05:43 CET

Fabien COELHO wrote:
> Dear SVN developers,
>
> MOTIVATION
>
> I find it irritating to have a separate command to check for the revision
> heterogeneity of a local working copy. The rationnal for 'svnversion' as
> given in the source file is that it could have been used in the svn
> building process. Well, it is not, and svnversion does still exists anyway
> after this patch.
>
> MESSAGE
>
> Create a 'version' subcommand so that 'svn version' behaves as
> 'svnversion' does.
>
> QUESTIONS
>
> I'm not so sure about the details in my patch:
>
> - could the functionnality be moved to some library and invoked there
> by both 'svn' and 'svnversion'? If so, which one?

libsvn_client

> - would the subcommand be better named 'revision/revisions' or some other
> name? Here there is a subcommand and an option with the same name...

Yes, if we are going to do this, we should *definitely* take the opportunity
to choose a better name.

> - what about 'svn rm subversion/svnversion'?
> add svnversion = exec svn version as a substitute?

No, just push the functionality down into libsvn_client, and let both svn
and svnversion call it.

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 2 14:07:31 2005

This is an archived mail posted to the Subversion Dev mailing list.