[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

invalid XML data after crash

From: Serge Wroclawski <serge_at_tux.org>
Date: 2005-09-23 17:49:55 CEST

Hello all,

I was directed here after the user list said that the problem I was having
was more appropriate for this list...

I am running svn 1.1.1 on an RHEL 4 box and my users use Apache to connect
to it.

Recently my users began reporting this error when doing svn logs:

svn: REPORT request failed on '/svn/myrepo/!svn/bc/3638/trunk' svn: The
REPORT request returned invalid XML in the response: XML parse error at
line 983: not well-formed (invalid token) (/svn/myrepo/!svn/bc/3638/trunk)

These complains began shortly after a machine crashed due to a funky bug
in LVM (the repository is on ext3 over LVM).

I ran a "verify" on the repository- that checks out.

I did a dump and restore on the repository- no change.

The users don't see errors on checkout, update or commit, or on more
limited svn log commands.

I'm not a subversion expert. I don't know where to look for this error,
but it scares the users, and I'm worried that it may signify something
more serious. Either way, I'd like to fix it if I can, and if it's a bug
in Subversion itself, work to fix it.

Any help anyone can provide would be greatly welcomed.

Thanks,

- Serge Wroclawski

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Sep 23 17:50:40 2005

This is an archived mail posted to the Subversion Dev mailing list.