[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Authz support in Svnserve

From: <kfogel_at_collab.net>
Date: 2005-08-26 20:44:50 CEST

Greg Hudson <ghudson@MIT.EDU> writes:
> On Fri, 2005-08-26 at 00:29 +0200, Branko Čibej wrote:
> > And woldn't it be nice if "b" were called "baton" instead.
> > Single-character variables make my froodleprog itch.
> We use single-character or two-character variable names for batons all
> over the code base.
> If Subversion were in C++ or Java, baton fields would be class
> variables, and we wouldn't have a "b->" or "eb->" in front of them at
> all. Since this is C, we have to do that work ourselves, but it makes
> sense to minimize the amount of syntactic fluff necessary to do so.
> Admittedly, too much of this makes our code look like early BSD code,
> which (to me) is completely impenetrable. But I don't think doing this
> for batons is too much. Longer variable names do not always improve
> readability, "i" is sometimes better than "loop_iteration_count".

FWIW, I had no trouble reading the "b->" in that code. Batons are a
common enough idiom that it seemed clear in context.

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Aug 26 21:44:55 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.