[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Authz support in Svnserve

From: Greg Hudson <ghudson_at_MIT.EDU>
Date: 2005-08-26 18:32:34 CEST

On Fri, 2005-08-26 at 00:29 +0200, Branko ╚ibej wrote:
> And woldn't it be nice if "b" were called "baton" instead.
> Single-character variables make my froodleprog itch.

We use single-character or two-character variable names for batons all
over the code base.

If Subversion were in C++ or Java, baton fields would be class
variables, and we wouldn't have a "b->" or "eb->" in front of them at
all. Since this is C, we have to do that work ourselves, but it makes
sense to minimize the amount of syntactic fluff necessary to do so.

Admittedly, too much of this makes our code look like early BSD code,
which (to me) is completely impenetrable. But I don't think doing this
for batons is too much. Longer variable names do not always improve
readability, "i" is sometimes better than "loop_iteration_count".

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Aug 26 18:34:02 2005

This is an archived mail posted to the Subversion Dev mailing list.