[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Issue 443 : post-commit hook (error) output lost: Step 3

From: <kfogel_at_collab.net>
Date: 2005-08-25 04:57:53 CEST

kfogel@collab.net writes:
> We usually allocate based on the variable itself, like this:
> sizeof (*commit_info)
> That way if we have to rev the type later, to say svn_commit_info2_t,
> there's only one line to change -- and no possibility of forgetting to
> fix the allocation and thereby getting seg faults :-).
> The name "svn_helpers.c" is a bit generic, and the "svn" prefix is
> redundant. How would you feel about "types.c" or "constructors.c"
> instead? That would be somewhat descriptive, while being generic
> enough to be useful for other constructors later.
> Thoughts?

I meant to say this in my earlier message, and then forgot:

No need to resubmit the patch. I can take care of the above changes
when committing. I just wanted your opinion on the new file's name
before I did anything.


www.collab.net  <>  CollabNet  |  Distributed Development On Demand
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Aug 25 05:57:22 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.