[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Issue 1628

From: David James <james82_at_gmail.com>
Date: 2005-07-22 20:19:18 CEST

Hi Steve,

Thanks for your updated patch!

> Log Message:
> Load a crash reporting dll on Windows when clients start up.
> subversion/libsvn_subr/cmdline.c : load the crashrpt.dll dynamically
Can you provide a little more detail? Please outline the changes you
made to each function.

From http://subversion.tigris.org/hacking.html#log-messages :
"The log message should name every affected function, variable, macro,
makefile target, grammar rule, etc, including the names of symbols
that are being removed in this commit. This helps people searching
through the logs later."

> +#ifdef WIN32
> +/* Client crash callback */
> +typedef BOOL (CALLBACK *LPGETLOGFILE) (LPVOID lpvState);
> [... snip ... ]
> +typedef LPVOID (*InstallEx)(LPGETLOGFILE pfn, LPCSTR lpcszTo, LPCSTR lpcszSubject);
> +typedef void (*UninstallEx)(LPVOID lpState);
> [... snip ... ]
> +LPVOID lpvState = 0;
> [... snip ... ]
> + UninstallEx pfnUninstallEx;
> + if ((crashDll)&&(lpvState))
> [... snip ... ]
> + pfnUninstallEx = (UninstallEx)GetProcAddress(crashDll, "UninstallEx");
> + (UninstallEx)(lpvState);
> [... snip ... ]
> + InstallEx pfnInstallEx;
> [... snip ... ]
> + pfnInstallEx = (InstallEx)GetProcAddress(crashDll, "InstallEx");
> + lpvState = (pfnInstallEx)(NULL, "crashreports@subversion.tigris.org",
SVN_VER_NUM);

It looks like you're still using Hungarian naming conventions. Is it
possible to fix this?

Thanks,

David

-- 
David James -- http://www.cs.toronto.edu/~james
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jul 22 20:20:12 2005

This is an archived mail posted to the Subversion Dev mailing list.