[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r15370 - in branches/python-bindings-improvements/subversion/bindings/swig: python/libsvn_swig_py python/svn

From: David James <james82_at_gmail.com>
Date: 2005-07-20 01:33:41 CEST

David James wrote:
> To make my code more clear, I propose to take the following steps:
> - Rename the _global_pool variable to svn_swig_application_pool
> throughout the SWIG bindings (including in the Perl and Ruby bindings)
> - Add a comment to the source code explaining why I created a global variable.
> Philip, does this sound like a good solution?
Oops. svn_swig_application_pool is a bad name for the variable,
because it is not only an application pool -- we are forced by
implementation details to use the same name for local pools. Would the
name "svn_swig_pool" be better?



David James -- http://www.cs.toronto.edu/~james
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jul 20 01:34:33 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.